Why am I receiving an error when adding Endicia in ecomdash?

The common error when adding Endicia as a shipper is: 

ERROR: 12507 The Certified Intermediary pass phrase is Incorrect. Error encountered. (Log ID: 48792)” will prompt when tried to generate a live label for Endicia

Cause: 

The PassPhrase of the account has been changed or wrong passphrase has been entered.

Please note that PassPhrase is NOT your "password".  The "password" is only needed to review your account through Endicia. 

Solution: 

1. Enter account number and pass phrase with the same spelling, capitalization, punctuation and spacing on the shipper details screen in ecomdash. 

2. If PassPhrase is forgotten; contact Endicia Customer Service or generate a temporary pass phrase on the link below.

http://www.endicia.com/support/forgot-passphrase.

Was this article helpful?
0 out of 0 found this helpful